Menu

CAN I USE: HERRAMIENTA PARA COMPROBAR COMPATIBILIDADES WEB

En la entrada de hoy vamos a hablar sobre una herramienta de bastante utilidad para cualquier desarrollador web, se trata de CAN I USE y es la biblia sobre la compatibilidad (css,html5,javascript) entre distintos navegadores. La herramienta es bastante intuitiva y fácil de manejar.

En el buscador podemos introducir funciones de javascript, css, HTML5…etc y nos dará información con todo tipo de detalles acerca de los navegadores compatibles, bugs conocidos en distintas versiones de navegadores, otras fuentes para consultar.

Can I Use nos aporta una serie de ventajas, tales como estadísticas o la posibilidad de comprar versiones de navegadores y nos da información sobre los elementos que soporta cada uno de ellos y los elementos o métodos que no son recomendables.

CanIUse-3

Además tenemos la posibilidad de comprobar todas las compatibilidades de un navegador en concreto escribiendo la siguiente url: tests.caniuse.com donde podremos comparar nuestro navegador con cualquiera de los que aparecen como opción.

CanIUse-2

 

 

Comparar cada propiedad individualmente…

CanIUse-1

Por si fuera poco, hay una extensión disponible para los que tengan instalado node y npm que nos permite hacer las consultas a través de la consola.
Para instalarla únicamente escribimos en nuestro terminal:

Para poder utilizar el comando Can I Use en nuestro terminal :

Y para consultar, por ejemplo, la propiedad transform:

Sin duda una gran herramienta que nos ahorrará muchos dolores de cabeza a la hora de programar cualquier sitio web.

¿Ya has probado Can I Use? 

0 Comentarios Responder

    Deja un comentario

    Su comentario(click en el botón para enviar)

    dos × 1 =

    Compartir

    This is a unique website which will require a more modern browser to work!

    Please upgrade today!